Files not transferred upload.txt and download.txt

server is running … ftp is working… check the pic for details…Please don’t give useless hints …as I am already fed up by seeing the useless forum replies from last one day…

Hi, @Harsh1997.
Here are my thoughts on it

  1. Your upload is failing with a 553 Could not create file
  2. Your client and server are on the same directory. We were asked to make the server directory as ftp_server and the client’s as ftp_client.

About this, there’s no incentive per se for anyone to reply in the forums. So, they are doing it to help others when they can. As this is also a learning phase, you can try replying to the posts that you think are “useless hints” and let them know why you think so. This way they’ll learn the mistakes they are making.

Reply to your points @nabhanpv

  1. I also know that upload is failing because of 553 could not create file …as it is written in the picture itself… but what to do now is the main concern

  2. Please check the picture carefully on the left file explorer … I think I have created the directories correctly ftp_server and ftp_client… correct me if I am wrong

@Harsh1997 Please try put command as :- put File_to_upload.txt Directory/where/to/upload/File_to_upload.txt

Sorry, I wanted to give you the satisfaction of finding the solution yourself by pinpointing the cause, incase you have missed to see it. Please understand this is a platform w/ students of all levels of experience. So, I think it’s safe to underestimate proficiency level than to over-estimate while answering questions.

Now, onto your problems

  1. Upload failing
  • 553 Could not create file if you have checked will find can be caused by insufficient permissions.
  • If you check the permissions of the directory you are doing put from (/home/crio-user) this is the output

drwxr-xr-x 4 0 0 4096 Dec 27 05:44 .
drwxr-xr-x 23 0 0 4096 Feb 14 23:37 …
drwxr-xr-x 24 1001 1001 4096 Feb 14 23:41 crio-user
drwxr-xr-x 6 1000 1000 4096 Dec 27 05:47 ubuntu

  • You can see that the directory (.) belongs to user with user id 0 which is the root and write permission is only for the owner, not to the group/others

  • Hence the current user, crio-user can’t write to the folder and therefore put command responds with 553 Could not create file

  1. Files not created even though its showing transfer complete for the get command
  • As @ssndhu01 suggested, the format for using get command is get file_path_to_download new_file_path or if you are giving only file names and not file path get file_name_to_download

  • Similar is the format for put command too

Nb: The second point in my earlier reply is wrong. Sorry, I just found out the server directory defaults to /home/crio-user whereas the client starts at the directory the terminal is in.

Hope it helps.

1 Like

I changed the permissions for crio-user to 777 still the same issue persists. Also, I am using the correct syntax of put and get commands but still don’t understand why it’s not working.

@hiteshkumar
What error are you getting?

I was getting the same error as mentioned in the image by @Harsh1997
But now it’s resolved.



Using these links I was able to resolve the issue.
@Harsh1997 you can try using these links if the problem is still not solved, let us know.

1 Like