Failure: External Client hasn't successfully downloaded file to Server

I’ve uploaded and downloaded files multiple times, but I still keep failing the unit tests.
I don’t know why.
Like I can see the uploaded file(in ftp_server) and downloaded file in (in ftp_client).
I can also see it’s being shown in the log


Am I doing anything wrong?

P.S. - I cannot open/view the log files(both ~/workspace/vsftpd.log and
cp ~/workspace/vsftpd.log ~/workspace/MYNAME-ME_QBOX/client_server/) without giving sudo permission.s Could that be a problem?

please check the taskboard and understand as to what has to be done. You will surely crack through this error :slight_smile:

Thank you.
Ohh it’s regarding uploads and downloads from mobile and desktop clients right?

For some reason, downloading isn’t working on my phone (it’s stuck on download screen).
Downloading on desktop client should be enough right?

EDIT: Yes, WORKED! :slight_smile:

Can you explain this please @reddybhargava?

How did you manage to transfer upload.txt from the client to the server using the put command? I have tried “put upload.txt /home/crio-user/workspace/ftp_server/” but it’s not working. Please help

You just have complete milestone task #3 properly to get past this.

You’ve to provide proper paths for both local and remote files

are you sure you giving the right address? check again