Fail in pushing git

user@suyash-sreekumar:~/workspace/suyash-sreekumar-ME_QBOX$ git push -u origin master
Counting objects: 80, done.
Delta compression using up to 2 threads.
Compressing objects: 100% (72/72), done.
remote: fatal: pack exceeds maximum allowed size
remote:
remote: ========================================================================
remote:
remote: stdin send error: EOF
remote:
remote: ========================================================================
remote:
error: remote unpack failed: unpack-objects abnormal exit
error: failed to push some refs to ‘git@gitlab.crio.do:COHORT_ME_QBOX_ENROLL_CRIO_LAUNCH_2020/suyash-sreekumar-ME_QBOX.git’

I tried force push but no point.
I did even check
my pcap files are less than a mb.
Please guide.
I had seen a post sent by gaurav in faqs.
I am not sure how to go about it.

@Suyash
Check the size of this folder suyash-sreekumar-ME_QBOX. Most likely due to a larger folder size.

May be you have stored the .pcap file in other folders(of large size)
or you have multiple .pcap files(if you have used -W with large number)

My .git take 80M space…
Why is that so?
Tried this code
git gc --aggressive --prune
reduced from 80 to 71 M .
Still too large.
How do I rectify it?

Hey guys got the solution with a little bit of searching.
Like @nabhanpv suggested checked my folder and noticed git folder was taking too much space.
It was due to pcap file which got commited.
Used the following linkto reduce the size from 80M to 1.4M


Thanks to @nabhanpv @senti143 for your suggestions. :grinning:
#LearnItByDoing

1 Like

Thanks @Suyash for letting us know what worked for you. Now we know how to decrease the folder size if we get hit by your error :smile:

1 Like