Error while using getForObject

while using getForObject I am getting error as if getForObjec is ambiguous as you can see below it gets underlined. May anyone tell what are the packages that I need to import

Following are my default import tried importing some other spring packages but nothing solved may you point out if I am missing any package

package com.crio.warmup.stock;

import com.crio.warmup.stock.dto.AnnualizedReturn;

import com.crio.warmup.stock.dto.PortfolioTrade;

import com.crio.warmup.stock.dto.TiingoCandle;

import com.crio.warmup.stock.dto.TotalReturnsDto;

import com.crio.warmup.stock.log.UncaughtExceptionHandler;

import com.fasterxml.jackson.databind.ObjectMapper;

import com.fasterxml.jackson.datatype.jsr310.JavaTimeModule;

import java.io.File;

import java.io.IOException;

import java.net.URISyntaxException;

import java.nio.file.Paths;

import java.util.ArrayList;

import java.util.Arrays;

import java.util.List;

import java.util.UUID;

import java.util.logging.Logger;

import java.nio.file.Files;

import java.time.LocalDate;

import java.time.temporal.ChronoUnit;

import java.util.Comparator;

import java.util.logging.Level;

import java.util.stream.Collectors;

import java.util.stream.Stream;

import org.apache.logging.log4j.ThreadContext;

import org.springframework.web.client.RestTemplate;

import java.net.MalformedURLException;

import java.net.URL;
@shoryajain @akashchhetri @amanagar

All the packages are already imported.
Are you giving the correct url?

yes I have formed an url object , by substituting the required things in the api link give in todo’s

All required packages are already imported. Are making an object of RestTemplate before using? If yes all you have to do is hover cursor over this line and read the error you’re having. then you can use right click and Quick fix option.

Can you please check the error given by IDE when you hover the pointer over this line