Error: "vsftpd can not locate users specified in ‘ftp_username’ :ftp" or "vsftpd: both local and anonymous access disabled"

Anonymous mode needs to be disabled in the config file to resolve this error. Also, enable the option to write to filesystem and option to allow local logins.

Make sure there are no duplicate configuration entries in the config file.

I followed the step but it is still showing the same error

Did you restart the server?

@gouravsardana I have followed all the above steps but still getting the same error!

Follow this topic.

i just want to start doing module 3 from start as i have done some mistakes in setting up ftp which i even don’t remember, please tell how to restore it from start and delete the existing module correctly.

Please don’t use ftp_username. You don’t have to do that.
You can start with a clean config file and follow instructions clearly.

Can anyone make my confusion clear?
There is a file named vsftpd_v1.conf in which the above specifications are made.
But we are asked to change the location of the file by modifying " vsftd_v1.conf"
Again we are asked to edit “vsftp_v1.conf”.

Are there 3 separate files?

Please pardon me if it is a stupid question but I am super confused. I am also not getting the “vsftpd.log” file in ~/workspace directory too.

This is the third time I have started doing the module from the beginning and still cannot figure it out.

That must be a typo. There is only vsftpd_v1.conf

Hey did you solved the error I am getting the same error now for last 12 hours , if help may u suggest somethin

1 Like

I’m having the same trouble as you. Have you resolved it?

write ftp_username:crio-user in configuration file

1 Like

update your vsftpd_v1.conf file to:
it works :v:

“Anonymous mode needs to be disabled” read this instruction carefully. Also, ensure to read the entire comment section before changing vsftpd_v1.conf variables.
There is no need to uncomment ftp_username