Error in ASSESSMENT failing abnormal connections file

For the 1st line i entered the first appearance of packet with ONLY [RST] and also tried with [RST,ACK]
2nd line the source port’s IP address
and in the 3rd , line i added the only two instances of [FIN,ACK] in my client_connection_file_transfer.pcap file.
BUT im still getting an error i have no idea what i’m missing. Please Help this is just nuts.

For what needs to be entered

  • First line: Packet number where an abnormal connection termination is first seen.
  • Second line: Who is initiating the connection termination (provide the IP address)?
  • Third line onwards: Use a previously connected pcap file for a normal connection termination between your laptop and the QBox host. Paste the packets that show a normal connection termination.

Either you have mentioned wrong packet numbers / IP address or please remove the additional spaces after your answers.

I tried i just dont know what im doing wrong, cuz i did exactly this ->

1st line - 1st occurrence of only RST packet
2nd line - the Source port IP address given in wireshark
3rd line - the only 2 occurrences of [FIN,ACK] in my client_connection file

Im telling you i have literally tried every combination possible. Can you please check my submission?

Hey, did you try filtering using the ip address?

I think you think you understand the purpose of the question, so you must know which ip address to use.

I used the IP address given in Wireshark (after NAT) then i also tried QBOX external and Internal IP address but still getting failed assessment

1 Like

You have wrong values in 1st line and 2nd line.
For 1st it is not ONLY RST packet, it is something else. Please figure it out.

I think @sashi_Crio.Do has said enough. Try looking at the links at the end of milestone to know the packet type.

Check for first reset RST flag and note the packet number.

Okay so i figured out and my 1st 2 lines are correct now for sure. But the assessment isn’t pushing now LOL i already did 10 pushes in past few hours. Should I wait for sometime?
Cuz when i push now it says it upto date but its the i cant see any new assessments

Have you pushed your code? i.e the new push must have some changes compared to the previous push.

Yeah i pushed it after changing the abnormal_connection file but my last push is seen as 9:19 but now the recent pushes after that are not showing.
Can you please check if my most recent file is correct?

Please specify the packet numbers as
Example

37, 38, 82, 83

I did in the 3rd line there were only 2. But im still getting that file as failed in assessment.

I’m pretty sure the 1st and 2nd lines are correct.
Even the 3rd line must be correct with respect to my client_connection file

Can you please check? @sashi_Crio.Do

The analysis or the explanation in the submitted files should not have brackets in the text. Please remove the brackets and any other special characters that may be present and submit again.

There are no brackets in my file. Im still getting error. Are my values at least correct?

There shouldn’t be brackets in any of your explanation files. for the 2nd line, just specify the IP address, no need of any explanation . Make sure you remove the extra spaces after your answers.

I have checked all files and removed all special characters, spaces. Even gave the direct IP in line 2 but still getting the error for pcap_check_connection_termination.py
so my abnormal file is still failing

Your file is named abnormal_connection_terminal_details instead of abnormal_connection_termination_details

1 Like

yepp. Done now thanks a lot. I cant believe i missed this. Please delete the post. Thanks a lot to the TAs for being helpful and patient @sashi_Crio.Do @Kiran

Instead of deleting the post :nerd_face: mark sashi_Crio.do answer
as your solution, It will help others :innocent: