ERROR : 500 Illegal PORT command. ftp: bind: Address already in use

I am getting
500 Illegal PORT command. ftp: bind: Address already in use .
Solutions on the internet suggest using ftp in passive mode, but it gives
227 Entering Passive Mode (192,168,87,62,111,85).
425 Security: Bad IP connecting.
. What should I do ?

use htop and find the vsftpd process and kill it then run the command.

That did not help.I killed the service, restarted it via the vsftp executable, and I am back with the same error

@chandra-kiran_crio getting same error when I’m trying ls command getting error image

@Saurabh_Crio_TA

Facing the same issue here.

Use ps -ef and check whether your port is engaged by vsftpd file or not

I checked It and It is not working. Port 8080 is occupied but port 8081 is not and I’m using 8081

It’s not engaged. I was able to hack around this problem by using passive mode and changing some properties in the vsftpd_v1.conf file.

Did you get a build success though?

Still working on the module. Will update you later.

I am also getting 425 Security: Bad IP connecting

You have to change your vsftpd.log file a little. (Add a new variable)
The ftp returns a private ip for your machine by default which is of little use in WAN or internet.
You have to return the public ip.

1 Like

did you get any solution for this?

you have to add one parameter in vsftpd_v1.conf. Search for the error and you will find what parameter need to be added

Yes, I found the solution, Thanks to everyone

can you tell what to do? still getting the same error

Set

pasv_promiscuous= YES

to disable the PASV security check that ensures the data connection originates from the same IP address as the control connection.

1 Like

did that but then also same error is coming

how to add to the file . For me its saying ::
Failed to save ‘vsftpd_v1.conf’: Unable to write file (NoPermissions

first change the ownership of the file then do that