Cp command fails

When trying to copy log file, I’m getting the following error.
cp: cannot open ‘/home/crio-user/workspace/vsftpd.log’ for reading: Permission denied

How to resolve this?

Change the permissions of the file you are trying to read and you are good to go.

Hey maybe you have to use cp command with admin permission or you have to change the permission of the file which you are trying to copying by using chmod command

same error with me and I gave that file all the permission it needs using sudo chmod -R o+r vsftpd.log, chmod +r, +w, +x with all the permission parameters.

but the same error is showing , i also tried sudo cp command but then also it does not copy the file

can you show me screenshot of error which you are getting

can you share the output of ls -l command in workspace directory.

change the owner of the file or use sudo with cp command. only root has read write permissions no one else.

i tried to use sudo with cp command

should i change the owner of file to root or crio-user?

but the problem is in dir clientserver file vsftpd.log

change the owner of that file to crio-user.