Couldn't push to remote

I have tried everything on google, created ssh public keys even. Please help!

crio-user@dashnabanita:~/workspace/dashnabanita-ME_QBOX$ git push origin master
remote: 
remote: ========================================================================
remote: 
remote: You are not allowed to push code to this project.
remote: 
remote: ========================================================================
remote: 
fatal: Could not read from remote repository.

Please make sure you have the correct access rights
and the repository exists.
crio-user@dashnabanita:~/workspace/dashnabanita-ME_QBOX$ git push https://gitlab.crio.do/COHORT_ME_QBOX_ENROLL_CRIO_LAUNCH_2020/dashnabanita-me_qbox.git master
['https://gitlab.crio.do/COHORT_ME_QBOX_ENROLL_CRIO_LAUNCH_2020/dashnabanita-me_qbox.git'] is not a valid Crio repository. Do you have any typos? You can only clone Crio repositories in your workspace.

I am also getting this error while using https over ssh.

Is your issue resolved?

No, trying to generate new ssh keys but it says permission denied most of the times.

You don’t need to generate new ssh keys. It all happens in the backend. Are you able to push your code normally without setting any ssh keys?

No, that is the reason I generated new ssh keys. The thing is I accidentally messed up with the branches and did some reset so it is not working as directed.

Is there any other way to get out of the problem?

I somewhat submitted code on GitLab but since I can’t push through VM, the assessment tab isn’t opening.

@Rahul-Crio.do o please help. If I can’t push changes to GitLab, then Assessment won’t open.

I have resolved this issue.

What did you do to resolve this issue?

I generated new ssh public keys and added to my gitlab account, then made the repository unprotected so that allowing all users to tinker with code. Since the VM doesn’t access connection over https, I had to use mirrors in git push and in place of origin I used git@gitlab.crio.do connection. I guess there is no dynamic port binding and I wasn’t able to tunnel https through ssh also. So, my goto command for now is git push git@gitlab.crio.do....git master