Connection timed out error in filezilla

My vsftpd server and ftp servers are running but still getting this error . I am using my vm’s ip as hostname , 8081 as port and username and password are also of vm.
Screenshot (27)

At a time only two connections can be established in the FTP,please close the ftp server on the Visual Studio terminal and try to connect.
This should work

I have restarted the vsftpd and ftp servers and tried to reconnect from filezilla but still same error

You don’t have to start FTP , on the terminal , just use the vsftpd server and connect to filezilla

tried that too. but still getting same error

Can you please check if you have made the following changes in the vsftpd config file, as given in milestone task 3

Yes, the changes are there but I am running vsftpd server as sudo , is that okay ? and error is still there


this is my log file .
I am getting failed to retrieve directory listing error in filezilla . I am stuck here from 2 hours . please help sir @Rahul-Crio.do

Have you enabled the passive ports in your config file?

yes sir, I have pasted all the commands given in milestone 3 to my config file

Make sure you have passive mode on, the passive ports configured correctly and port 20 turned off etc. Spend some time studying the error shown, both in filezilla (for client side) and vsftpd.log (for server side) and see if you can figure out what fix that error needs.

Sir faced similar issue did all mentioned related to passive port but the error still persists of connection time out

make sure your visual studio code is not popping up a notification about not saving changes in config file and check the permissions of your config file . I had the same problem and by changing permissions it was resolved

What permissions are to be changed can you please tell? @Akash_gupta

permissions which allow user to read and write in a file

This could not my error in filezilla