Compilejava fail!

suddenly in annual-return-app directory i get 14 java error!!
I haven’t make any change on it so why i get this error.Because of this error i am not able to ./gradlew build bootrun command. Please help !!!

In new terminal run ./gradlew build then it will be fine.

yes , this command run successfully but errors still exist.

Have you tried resting workspace?

let me try check it !!

Still i am getting those error !!!

and Path can’t be resolve !!

Please Help!!!

Hey @jaydippansuriya Try this if this can help

i already tried it but doesn’t help !!!

ok @jaydippansuriya looking into this

Hey everytime you restart your workspace, the local mavan repository is flushed.
Run this command before starting server - ./gradlew verifyMavenJarsCreated
@jaydippansuriya

I am also facing the same issue
tried all of this : restarting the workspace a couple of times / gradle clean build
i can easily locate the jar file at : /home/crio-user/.m2/repository/com/crio/warmup/annual-return/1.0.0
but still the annual-return-app somehow can’t locate it
i am getting this error while performing the sudo ./gradlew build bootrun

Caused by: org.gradle.internal.resolve.ModuleVersionNotFoundException: Could not find com.crio.warmup:annual-return:1.0.0.
Required by:
project :

You need to remember two things

  1. do you find jar and pom both located in the directory?
  2. have you used sudo by any chance?

I am still facing same problem.
In my ME-QBox ans annule-return there is jar file.But no .pom file in any directory.

Please help me!!!

Can you show me the output of ls -l /home/crio-user/.m2/repository/com/crio/warmup/annual-return/1.0.0

I have intentionally put sudo bcz without sudo it gives a error even though i have given exceute permission to it . I have mentioned the error code below
Error: Could not find or load main class org.gradle.wrapper.GradleWrapperMain

Check if your locally building maven repository for the code

thanks all for help i think there was an issue in permission while is was cloning so it wasn’t executing thew gradlew to run annualreturn app removing the whole annual-return-app and cloning it again fixed the bug

carefully follow this you are missing something that’s why your pom.xml doesn’t get created
Also check whether ./gradlew verifyMavenJarsCreated is giving success message as it checks for both the files

Hello i am getting error while execute above command …