Build Failure for module1

I am getting correct output when i run ./gradlew run --args=‘trades.json’ on the terminal but when i submit my code i am getting build failure. Also I am getting build failure for com.crio.warmup.stock.ModuleOneTest which is empty in my workspace. I am not able to figure out what they are evaluating in this testcase. Please help. @ajay-crio @sridherj-criodo

there are internal test cases that they evaluate .
please check your code is handling all cases that may come across it.

I checked all the cases and its working fine on terminal.

ensure that there should not be build failure by running this command - “./gradlew build” on the terminal.

There are no build failure on terminal after i run “./gradlew build”

It means there are some internal test cases which your code is failing. You need to check your logic and ensure it fails no corner cases.

Have you solved this issue ?

Make sure your logic is correct and there are also hidden test cases which might fail for your logic :slight_smile:

I looked into the UnitTesting.log and it says “Build Failed”. But when I do “./gradlew build” in terminal , build gets successful.
So, is there an issue in the logic of extracting symbols or something else which I am missing?

In milestone 1, It is written that we have to print all the trading data.
And in milestone 2 it is written that we have to print the list of symbols.

So de we need both of them in the output?

The unit testing log shows build failed because of some internal corner test cases that your code is failing on. You should try checking your code for that.

can you please take a look at my question

Tbh I don’t remember it exactly and since I can’t access my system rn, I’ll advise you to proceed word by word as per the description given.

You just have to return a list in your function and only a list of string should be there in your output.

Hi make sure that you haven’t done any hard coding in your program

can you please be precise i have also implemented it to match this list {“AAPL”, “MSFT”, “GOOGL”}
and I’m still failing

You might did some hard code. Check you code.

is it a necessity to make a pojo class?

There is already a pojo class made for you.
Refer this.

1 Like


we are expecting this result only right???

1 Like