Build Failed with no other info

My assessment results:

2020-02-29 22:05:01,017 unitTesting INFO Running gradle test
2020-02-29 22:05:20,856 unitTesting INFO Gradle test run complete
2020-02-29 22:05:20,858 unitTesting INFO Build failed

Please Help @Rahul-Crio.do @ajay-crio @anand-crio @chandra-kiran_crio !!! I’ve tried almost everything.

Posts consulted:

  1. Assessment is failing. I didn't hardcode anything, and I have checked for all exceptions
  2. Assessment failing with this error: Task `qmoney:compileTestJava` failed!
  3. Build Sucess! but assessment failed
  4. qmoney:compileTestJava failed at assessment but local build is successful

Mention the names of test which are failing.

On the assessment page or in the assessment report in your mail, there will a list of test(s) which are failing. Please share that.

No such thing is mentioned.
The testing log is as I have given under assessment results.

It does come in mail. Please check it again. Logs won’t contain anything in this module.

  • An issue was encountered while running your assessment:
  • alertTask qmoney:compileTestJava failed!
  • actionDebug your code to figure out what went wrong
  • Log files (if attached) can help you debug the issue. Fix it and submit for assessment again.
  • User & ME Details
  • Username: shabbirchatrissa
  • Module: ME_QMONEY_MODULE_CALCULATIONS
  • Micro-Experience: ME_QMONEY
  • Build Report Last run: 3/1/20 4:47 AM
  • Iteration: 8
  • Trigger: Started by Gitlab Push
  • Stage: Unit Testing
  • Commit Details: xyz

This is what the email contains.

And the unit testing log that comes with the email contains the same thing as what I originally sent.

Even I am stuck here.
The build is successful but while submitting for asssessment,
I also get the same error.

Tell me if you find something @Suyash .

@Rahul-Crio.do @ajay-crio @anand-crio @chandra-kiran_crio just give us a hint in which direction to work.

If any tests were failing I would at least have an idea where I am going wrong, here I am completely clueless.

1 Like

Let me check your code first.

You are calculating the annual return in a wrong way.
Hint- check your annReturn :slight_smile:

@gouravsardana please let me know my issue.

I’ve change the annReturn (|totalReturns|) still unable to get past this issue.

Did you modify anything inside the test file?

Sir, i changed annualizedReturn/getAnnualizedReturn to annReturn but then i read your answer on another such post and i undid changes by using git log and git show.

Any updates, sir? @anand-crio

Message indicates that you have compilation error.
Which means you have modified some method signatures. Provided by us.
Check if you have done that.

A quick check is to verify if you have modified any test file. If you modify anything in test, it will make your local build pass, but the assessment will fail.

1 Like

I’ll check it again sir.