Assessment fails at compilation

Hi,

After completing QCalc. I have pushed the changes but in the assessment tab, I am getting a compilation error.

See the Setup.log and Compilation.log messages

Setup.log

2020-07-05 18:11:19,681 setup-9f28a5e8-c36b-43fc-9e69-34946b0b997f INFO User repo cloned!
2020-07-05 18:11:19,723 setup-9f28a5e8-c36b-43fc-9e69-34946b0b997f INFO Commit id: ab8d52305ab028676fa372014531dfa9d3520ad1
2020-07-05 18:11:19,725 setup-9f28a5e8-c36b-43fc-9e69-34946b0b997f INFO Module ID: ME_QCALC_MODULE_INHERITANCE
2020-07-05 18:11:19,725 setup-9f28a5e8-c36b-43fc-9e69-34946b0b997f INFO Setup complete!

Compilation.log
2020-07-05 18:11:20,207 compilation-9f28a5e8-c36b-43fc-9e69-34946b0b997f INFO Running gradle to check for compilation errors

I cloned the repo and tested it’s getting compiled successfully in my workspace. But it’s not getting compiled in the assessment.

Could anyone let me know why the compilation is failing?

@anas-criodo - Can you help Vishal to find the compilation logs?

Vishal, if you are done with Module-5 (assessment pending), kindly proceed with the next ME. Don’t have to wait on this.

@vishal1 it looks like there is no gradlew binary present at the root level of your repository, due to which assessment is not able to compile your code.
The code hierarchy seems to have been messed up in your repository somehow, i’ll ask a TA to get in touch and help you with the same.

Closing this topic as your issue is resolved by the mentor. If it is still not resolved, Kindly un-mark the accepted solution or create a new topic and post this question as a reference link in the description of the new topic.