Assessment failing even after successful recording into log files of pic transfer to workspace and other commands

2020-02-10 20:14:53,965 unitTesting INFO Running command_runner
2020-02-10 20:14:54,107 unitTesting INFO Running setup.sh…
2020-02-10 20:14:55,162 unitTesting INFO Module setup complete!
2020-02-10 20:14:55,169 unitTesting INFO Starting assessment…
2020-02-10 20:14:55,171 unitTesting INFO Assessing confirm_server_listening.py
2020-02-10 20:14:55,476 unitTesting INFO Failure: Could not find the entries to confirm that server is listening in file /divyashahi139-ME_QBOX-fca5aa7a-4c41-11ea-9ccf-112d2ddac5b9/divyashahi139-ME_QBOX/client_server/server_connections

2020-02-10 20:14:55,480 unitTesting INFO File: confirm_server_listening.py | Status: TEST_STATUS_FAILURE
2020-02-10 20:14:55,482 unitTesting INFO Assessing confirm_client_server_communication.py
2020-02-10 20:14:55,735 unitTesting INFO Failure: Local Client hasn’t successfully connected to Server

2020-02-10 20:14:55,740 unitTesting INFO File: confirm_client_server_communication.py | Status: TEST_STATUS_FAILURE
2020-02-10 20:14:55,742 unitTesting INFO Assessing confirm_external_client_server_communication.py
2020-02-10 20:14:56,069 unitTesting INFO Failure: External Client hasn’t successfully connected to Server

2020-02-10 20:14:56,076 unitTesting INFO File: confirm_external_client_server_communication.py | Status: TEST_STATUS_FAILURE
2020-02-10 20:14:56,080 unitTesting INFO Assessment finished!
2020-02-10 20:14:56,085 unitTesting INFO Starting cleanup…
2020-02-10 20:14:56,144 unitTesting INFO Running cleanup.sh…

I have successfully uploaded pics from my phone as well as local machine to workspace folder and that’s even recorece in my log file than why my assement is failing I am unable to understand as every entry of my command is in my .log file please help, now I am unable to understand what’s wrong

Please post this in the appropriate section. Did you copy your log file to the correct folder?

1 Like

yes it’s in workspace folder I have checked everything, it’s working fine location is right and every thing is recorded in it from start to end.
I can even post ss, which right section u mean

I think you are supposed to copy the log file to the client-server folder after you are done uploading/downloading files. Have you done that?

1 Like

no my log files resides in workspace folder only

okay I am trying this. Means I need to leave one log file to workspace folder and a copy of it in client-server folder too.

Yes. Push your code after that. The one in workspace doesn’t matter. It’s the one inside client-server folder that gets submitted for evaluation.

1 Like

thank you so much @S4G4R ! mother load of thanks it passed all test cases I was behind it past 2 days but got no help thanks a lot :relieved: :relieved: :relieved: :relieved: :relieved: :relieved:)

No worries! :slight_smile:

1 Like