Assessment failed, not able to see assessed test cases

I am not able to see which test cases failed. All the test cases are passing when I run ./gradlew build

Hey,

There is a possibility that this might be a hidden test case from our end.

  • Make sure you are calculating number of years properly
  • Also check if you have added correct BuyPrice and SellPrice
  • Hint: Use ChronoUnit to calculate numbers of days between two dates and then convert that value into years. (totalYears=totalNumberOfDays/365). Make sure to use Double for everything.

If everything is calculated properly, you might have made a small logical mistake somewhere. Use debugger to find it.

Even the passing test cases are not showing.

Could you atleast tell how many test cases are evaluated when I run “./gradlew build” locally ?

Hey, have changed your test files? It says unit testing failed can you check your unit testing log.

There can be 12-16 test cases locally

No I did not. There is a PortfolioManagerApplicationTest.java that has 7 test cases. Then there is a ModuleTwoTest.java that has 5 test cases. And then I have ModuleOneTest.java and ModuleThreeTest.java both of which are empty.

Hey, i checked your code and your ./gradlew build is failing. Also seems like you have’t resolved the merge conflicts in PortfolioManagerApplication.java file

I reset the repo to my previous commit and then did the setup for module 3 again. Now it worked. Thanks

Cool. Now, ill be closing this topic. If the problem still persists feel free to raise a new query. Good Luck for future modules :slight_smile: