Active and passive mode in module 3 milestone 2

i am getting illegal port command although i used pass but i read on web that passive mode uses 21 port but in .conf file it is mentioned we have to use port 20.
what to do?
ps : i have already added pasv_promiscuous=YES in .conf file

You should not have to tinker with the promiscuous mode.
Follow the instructions carefully.
Port 20 is used for data and with pasv mode you can change the data ports to a particular range instead of 20. Pasv mode is only needed in milestone 3 for external file transfer.
Port 21 is the default for control connection. This we have recommended changing to 8081.

connect_from_port_20 should be YES or NO in vsftpd_v1.conf file for external file transfer?

it should be no as mentioned in task board

after setting connec_from_port to NO…now i m not able to start the server it is showing this error
500 OOPS: bad bool value in config file for: connect_from_port_20

wait in milestone 2, you don’t need to set any value .its default using 20.
and this error “bad bool”.is solved on forum already please check it out.