7 times build failure in module 3..please help tried everything

I can’t find my solution, sir the problem is my assessment of 3rd module is failing (unit test) its showing: “Local Client hasn’t successfully connected to Server”

i have tried every step given on forum, also i have checked my log file, its showing 230 login successful after each ftp request from ftp_client and ftp_server also its showing transfer complete everytime, i have checked my log file getting updated everytime i am requesting for a connection

and transferring files. please help I am on stuck on it since monday morning.

and transferrig files*
i have even traced every line of a log file.

Is your problem solved?

no. I am still stuck,it failed 8th also.
i even created another log file.
i am sure now everything is good.
please help me

+1
Same is happening with me

please share if you get anything.

I am also getting the same error. Check if port 21, 8081 both are allotted to vsftpd_v1and try changing the vsftpd_v1.conf to :

ftp_username=crio-user
pasv_enable=YES
pasv_promiscuous=YES
pasv_max_port=2000(max_range_port_ip_address)
pasv_min_port=1025(min_range_port_ip_address)
pasv_address=3.6.164.108(your_server_ip_address)

while I am getting :

ftp> cd ~/workspace/ftp_server
250 Directory successfully changed.
ftp> ls
500 Illegal PORT command.
ftp: bind: Address already in use
ftp> pass
Passive mode on.
ftp> ls
227 Entering Passive Mode (3,6,164,108,6,48).
ftp: connect: Connection timed out

Yes my problem is solved.While connecting to local client use 0.0.0.0 8081 instead of workspace ip and again try to transfer files .

i don’t understand your post sorry. Can you elaborate?

yes,i did that . 0.0.0.0 8081 when locally and workspace ip when externally

Since initially ftp is enabled on port 21 and later converted to 8081 during the milestones, you need to check if vsftpd_v1 is running on 8081 port only not on port 21. for that you can get pid of ports by using netstat and then check which process is running.

Since, ftp was written way before firewalls and NATs it prefers ipv4 connection or you can call it pasv rather than (ipv4+ipv6) as of now. So, I enabled pasv connections and added a pasv_address as server’s ip address. You can provide minimum port range for your ip address and maximum port range for your ip address as well. But I am getting a connection timed out error.

I didn’t understand when you say externally on workspace ip address and internally on 0.0.0.0 8081. Have you used ftp inside ftp? Like you opened ftp server on QBox and then worked through the milestone and created another inside the previous ftp?

when i am doing netstat i am getting 8081 listen, i guess that’s what required.
and i was saying
i started my server
cd ftp_client
ftp 0.0.0.0 8081
provide credentials
put upload.txt
bye
then cd ftp_server
ftp 0.0.0.0 8081
credentials
get upload.txt
put upload.txt
bye
cd ftp_client
provide credentials
get download.txt.
bye
this is my process for local transfer

for external i am taking 2 mobile phones download andftp in both and connect them using my workspace ip and 8081 port upload and download files.
and simultaneousy checking my log file everything is logging in my log file.
am i doing right?

check for pwd command on ftp server and you will get to know where you are then cd to required directory and put and get files.
Now, everything is working for me. I think the glitch for me was due to my unstable internet connection.

i got the solution. crio tech lead solved it, i was creating wrong file

Same Problem showing error in 2nd milestone
but i can’t find any

well i changed the name of the log file by mistake. that’s my error.
if it helps.

Have you got build success ?
I am getting TEST_STATUS_FAILURE for confirm_external_client_server_communication task. Can you please suggest what steps you have taken in milestone 4 ?

tell me what are you doing in milestone 4?

Issue resolved. Thanks anyway !

Yes, this works but why?

2020-02-09 10:10:41,047 unitTesting INFO Running command_runner
2020-02-09 10:10:41,097 unitTesting INFO Running setup.sh…
2020-02-09 10:10:41,557 unitTesting INFO Module setup complete!
2020-02-09 10:10:41,558 unitTesting INFO Starting assessment…
2020-02-09 10:10:41,558 unitTesting INFO Assessing confirm_server_listening.py
2020-02-09 10:10:41,856 unitTesting INFO File: confirm_server_listening.py | Status: TEST_STATUS_SUCCESS
2020-02-09 10:10:41,857 unitTesting INFO Assessing confirm_client_server_communication.py
2020-02-09 10:10:42,147 unitTesting INFO Failure: Local Client hasn’t successfully connected to Server

2020-02-09 10:10:42,149 unitTesting INFO File: confirm_client_server_communication.py | Status: TEST_STATUS_FAILURE
2020-02-09 10:10:42,149 unitTesting INFO Assessing confirm_external_client_server_communication.py
2020-02-09 10:10:42,448 unitTesting INFO Failure: External Client hasn’t successfully connected to Server

2020-02-09 10:10:42,449 unitTesting INFO File: confirm_external_client_server_communication.py | Status: TEST_STATUS_FAILURE
2020-02-09 10:10:42,450 unitTesting INFO Assessment finished!
2020-02-09 10:10:42,450 unitTesting INFO Starting cleanup…
2020-02-09 10:10:42,491 unitTesting INFO Running cleanup.sh…

this is my log file and i think i am also facing the same issue so could you please help me