500 OOPS: vsftpd: refusing to run with writable root inside chroot()

I have taken out write permission for usr/share/empty and I have also verified it by ls -l command but did not work. I have even put in allow_writeable_chroot=YES configure but nothing worked. Please Help me!
chroot

Hey, please understand the Config file Variables and go through the TODO’s mentioned in the config file
and understand as to what possible can be done.
Hint: This issue is possibly caused by 2 boolean options:
These options can allow local login of users and write files.

Thanks for your answer but I have already overcome the issue. I was not able to take out write permission from the empty directory.