500 OOPS: vsftpd: not found: directory given in ‘secure_chroot_dir’:/usr/share/empty

in which location do I create this directory?

the whole path is already given. Just use that

@harshsri2208 In the location it is asking to. [/usr/share/empty]

i tried that . but do i have to make it inside QBox directory or in this location ~/usr/share/empty ?

in the give location

hey,have you solved it??

if you are still stuck there then create this directory using mkdir command in linux
/usr/share/empty

2 Likes

actually i am getting 550 perimission denied…any idea?
ps: my anonymous enable is NO

what about write enable, and check all the configurations properly.

can you tell me configurations of the conf file, i have made all the required changes

I am getting the same error. Were you able to solve it

the directory you are creating is in usr/share/empty is wrong. Tha man page of vsftpd.conf says that secure_chroot_dir need to be a directory that is empty. So create an empty directory

Try making this directory from root.

for troubleshooting check this link https://vanducuy.wordpress.com/2010/06/27/vsftpd-configure-and-troubleshooting/

2 Likes

Hey! is it resolved yet?

Creating empty directory in the mentioned location (/usr/share) resolves the problem. Make sure to restart the QBox Server after making changes in vsftpd_v1.conf .

1 Like

Make that directory. For me, it worked after creating the directory

Worked for me…thanks

Use sudo command to make this directory.