500 OOPS: vsftpd: not found: directory given in ‘secure_chroot_dir’:/usr/share/empty

I used workspace ip as qbox-host.
I am getting this error.
500 OOPS: vsftpd: not found: directory given in ‘secure_chroot_dir’:/usr/share/empty

just create the directory shown in error

1 Like

@gouravsardana @visargdesai creating directory worked.
but getting this error now while running put command

ftp> put upload.txt
local: upload.txt remote: upload.txt
500 Illegal PORT command.

search for this error. You will easily get the answer

@visargdesai I tried different mode. But stil unable to upload or download the files.
getting this error:
ftp> put upload.txt
local: upload.txt remote: upload.txt
227 Entering Passive Mode (192,168,70,193,65,135).
553 Could not create file.

I am also stuck at this point

I even tried changing file permission and changing vsftp_v1 ownership to root.

in which location do I create this directory?

the whole path is already given. Just use that

@harshsri2208 In the location it is asking to. [/usr/share/empty]

i tried that . but do i have to make it inside QBox directory or in this location ~/usr/share/empty ?

in the give location

hey,have you solved it??

if you are still stuck there then create this directory using mkdir command in linux
/usr/share/empty

2 Likes

actually i am getting 550 perimission denied…any idea?
ps: my anonymous enable is NO

what about write enable, and check all the configurations properly.

can you tell me configurations of the conf file, i have made all the required changes

I am getting the same error. Were you able to solve it

the directory you are creating is in usr/share/empty is wrong. Tha man page of vsftpd.conf says that secure_chroot_dir need to be a directory that is empty. So create an empty directory

Try making this directory from root.