500 OOPS: vsftpd: cannot locate user specified in ‘ftp_username’:ftp

I am still getting the error even after un-commenting and restarting.Also I can’t find my vsftpd.log file.Please help.

Hey, Please refer to your vsftpd config file, and refer the guidelines as to what has to be done.

Have you resolved this error?

Is this problem solved for any one?
I am still facing the same problem.
I spent more than 4 to 5 hours.

Well now I am getting a different error.

what is the exact error u are facing???..

500 OOPS: vsftpd: not found: directory given in ‘secure_chroot_dir’:/usr/share/empty

I am facing same issue

Do a google on with the same line. You will get an idea how to resolved this issue.It’s pretty simple. if you still can’t figure it out do reply to this reply and I will try to help you out.

Yes I have solved the problem I think.

@rutvij2811 @Patralekha can you please tel how to figure it out as i am also getting the same and not able to resolve.

are you running as a root while changing the ownership of the required files ?

yes i am running it as root user

Share all the uncommented parameters of the conf file.
Atmost I can give you a hint or a link to the solution already there in the forum. (If I can figure it out that is)

This is it @rutvij2811

anonymous_enable=YES
dirmessage_enable=YES
xferlog_enable=YES
connect_from_port_20=YES
xferlog_std_format=NO
listen=YES
listen_port=8081
vsftpd_log_file=/home/crio-user/workspace/vsftpd.log
syslog_enable=NO
log_ftp_protocol=YES

So the module which requires you to run as root also requires an authentication.(This is the best hint according to me)
What type of user cannot authenticate ?
make changes to your conf file now if you figured it out.

The more I am trying to resolve, more deeper I am going. Once it was working without specifying ftp-user. Now it is not working

Connected to 3.6.55.221.
500 OOPS: vsftpd: cannot locate user specified in ‘ftp_username’:ftp
ftp> pwd
Not connected.
ftp> !pwd
/home/crio-user/workspace
ftp> ls
Not connected.
ftp> !ls
QBox xaheer3scc-ME_QBOX
ftp_client xaheer3scc-ME_QEATS_REVIEW_MP
ftp_server
ftp> lcd
Local directory now /home/crio-user/workspace
ftp> cd
Not connected.
ftp> get
Not connected.
ftp> bye
why 500 OOPs plz help someone?

@sammynerd did you solve? how please tell as i have been stucking here since last two days.

You need to add the ftp_username parameter in the conf file to make it work