500 OOPS: SSL: ssl_enable is set but SSL support not compiled in

I got this error after I have configured the vsftpd.config file while setting up a secure FTP server.

Have you checked the location of the certificate and key mentioned in the conifg file is correct?

Make sure you have enabled debug_ssl in the vsftpd config file.

You might find this link helpful: https://www.liquidweb.com/kb/configure-vsftpd-ssl/

Did you generate proper key and certificate files and then made the changes to vsftpd.conf?

Make sure you are running the vsftpd_secure binary that was provided as part of this module.

Yes, I have tried it to run with the vsftpd_secure binary file but it then says “sudo: ./vsftpd_secure: command not found” error.

You should be able to resolve this :slight_smile: Confirm you are executing this from the same directory where this file is present.

Same error even when I provide full path.

Have you given it permissions to be an executable file?

Yes, now it’s working fine.

I did not find any vsftpd_secure binary anywhere

It is in the Qbox directory

Have you run the setup.sh as instructed?

Yeah I think i skipped that part by mistake. got the file