500 OOPS: SSL: cannot load RSA certificate

I created certificate and key successfully. But after that when I ran vsftpd then this error occur.
@amanagar, @Kush_Crio_TA, @chandra-kiran_crio

https://forum.crio.do/t/unable-to-create-a-ssl-certificate-and-key/6682/6

@Adityas I created certificate and key in the same place.
/etc/ssl/private/vsftpd.pem
What I have to change?

@Adityas when I am trying to generate new certificate and key then following error occur.
Can't load /home/crio-user/.rnd into RNG

In milestone task 2…they have mentioned the exact location where to store them.
so check it out…And then specify them in config file

you may find this helpful

Even I am facing the same issue

@megha create the key and certificate in ~/workspace directory.

Am i heading the right path?

If your cert and key files are generated successfully, you can ignore this warning.

  • Make sure you are generating the files inside workspace so you don’t lose them after the suspend.
  • Config file should have the absolute path to these files before running the server.
  • Refer the references for this milestone.

I had created the key and certificate earlier. However since the workspace got hung in between I was forced to reset the workspace. So I eventually lost the key and certificate. However when I try to repeat the same procedure over again, it keeps showing the error “Problems making Certificate request”

Any help @ankitraj @Soumyadip

If you created the key files inside workspace directory, it will still be there, you do not have to repeat the procedure again.
Move to the directory where you had applied the openssl command and search for the relevant certificate and ket files. Once you find them, proceed with the next step.

At first I had created it under /etc/ssl/private/

Then you’ll have to repeat the procedure. As I can see from your screenshot, you are creating the certificate file and the key file under the exact same filename. Don’t you think this might effect. Do you get 2 different files for cert and key under workspace?

Hey @megha I faced the same problem as you faced and when I tried to recreate certificate I got that error. I just simply reset workspace and create the certificate and key in workspace dir as you shown and this solved my issue. Try this.
And if you modified the conf file with previous path then change that.

@megha
Quick word of caution

@megha

This might solve your problem

You should comment the changes that you did in the vsftpd.conf file for enabling ssl and then execute the openssl command to generate key and certificate. This would successfully generate the key and certificate, you can now uncomment the changes which enabled ssl in vsftpd.conf. I had the same issue so I resolved it in the above manner.

I had this issue, for me, I specified wrong absolute path location of the certificate in vsftpd.conf.