500 OOPS: run two copies of vsftpd for IPv4 and IPv6

I got this error on running vsftpd_v1 and vsftpd_v1.conf file using
sudo ./vsftpd_v1 vsftpd_v1.conf
I set -
#listen=Yes
listen_ipv6=Yes

See if you’ve set both ipv4 and ipv6 this causes an issue. Reach the comments in the. conf file for better understanding.

Hey, our task is to connect to an IP, please don’t use ipv6, Please refer to your config file to understand the task.

Sir when I use the following -
listen=Yes
#listen_ipv6=Yes
then an error occur “can not bind ipv4”

1 Like

YES same proble, here,

I can’t even see listen_port here

You have to add listen_port on your own set it to 8081.

I got it, thank you
anyway

My problem is solved, use the following commands -
sudo chown root vsftpd_v1.conf
sudo chmod +x vsftpd_v1.conf
sudo ./vsftpd_v1 vsftpd_v1.conf

after executing 3rd command it is showing error
crio-user@snigdhabhosle:~/workspace/QBox$ sudo ./vsftpd_v1 vsftpd_v1.conf
500 OOPS: could not bind listening IPv4 socket

I am also facing the same problem, “500 OOPS: could not bind listening IPv4 socket”.
I also examined the status of vsftpd service using ps -ef | grep vsftpd. I got the above error when I executed vsftpd_v1 vsftpd_v1.conf.

Did anyone find a solution to the problem, because I have tried almost everything but could not get it to work.

how to resolve this error

You need to comment out listen ipv6

why is it not connecting?

You are not using filezilla for local ftp. So use workspace ip as host