500 illegal port error

can someone please tell me how to fix this? @Kiran
i’m on milestone #2 of mod 3

Can you check if the file upload.txt actually exists in the current location and if it does exist, does it have the correct permissions.

yeahh. it does exist and i also give 777 to its permission. still the same error.

Can you tell me the initial command that you used to start the ftp client?

ftp <workspace_URL> 8081

Did you use workspace url or ip address?

the IP address …

Try using ftp -p 8081

with the ip adress right

1 Like

You dont have to use workspace ip

1 Like

I just read up on the milestone you have to use the local client, think what would be the address for that.

Try one thing.
Start the server
Then use netstat -an
And take a look at address associated with port 8081

asa

now i am getting this

you mean 0.0.0.0 …

1 Like

You are in right direction . Try it

sws

have you set the values for pasv_min_port & pasv_max_port
if yes then check if there is another server is running or not
if yes then kill that server
for reference see this
https://www.computing.net/answers/linux/vsftpd-500-illegal-port-command-error/31587.html

You have to use the address. My mistake.

Did this work @gokulsarath

sws

it worked but