426 Failure writing network stream

When I’m using FTP get command on ~1GB file I’m getting this error: 426 Failure writing network stream. I’m not able to understand what it means? and my original file was also corrupted.
@amanagar
@chandra-kiran_crio

Are you using a local client as recommended?
Is the 1 GB file outside of the /home/crio-user/workspace directory as recommended?

yes it is in /home/crio-user/ftp_server as per instructions.

@Kiran
In module 4 milestone 2 I’m having same error code

426 Failure writing network stream

and I’m bit messed up in milestone 2 there were server which are not running and showing error

500 OOPS: 421 Service not available, remote server has closed connection

weather I have to include or exclude these servers in cpu_usage_version file

Keep in mind that some versions are faulty. Read through all milestones, you might have a better picture.

please help me with this issue of 426. I’m getting this error.

If you see the same behaviour with v1, then it is some other setting that must be a problem. V1 doesn’t have any issues.

  1. I’m facing 426: Failure writing network stream in many versions even now in the one which I used for Benchmark. Please help we with this. It’s been 4 long days I’m not able to resolve and understand where is the problem. I Googled it and found the error is because of some firewall and some are justing suggesting to edit config file (which I think we don’t have to do that).

  2. do we have to exclude all the faulty version from cpu_usage_version and analysis file for similar?

Some day version works fine and in another it justing throwing this weird error.

May be a network issue. Repeat multiple times to be sure of the behaviour.

I was also getting this error. It was somehow resolvd but now I am unable to get file and permission is denied

I’m repeating it multiple times When this error occurs my input file corrupts (file size become 0). :cold_sweat::cold_sweat:

Check if the source and destination file are the same.

I’m just getting this error after executing FTP command in respective folders. and it’s shows same file name on remote and local.

Since you are using a local client, I was asking if you are trying to get a file from a directory to the same directory?
Can you recreate the file in one place (either ftp_server or ftp_client), delete it from the other place and check if file transfer works correctly?

ftp> get ~/ftp_server/testfile
local: /home/crio-user/ftp_server/testfile remote: ~/ftp_server/testfile
200 PORT command successful. Consider using PASV.
150 Opening BINARY mode data connection for /home/crio-user/ftp_server/testfile (1048576000 bytes).
426 Failure writing network stream.
327680 bytes received in 0.00 secs (558.0357 MB/s)

Why is it transferring files incompletely and giving 426 Failure writing network stream.?

  1. The sample file is outside of workspace(In /home/crio-user/ftp_server)
  2. The directories are different.

Is this with the benchmark version, i.e. vsftpd_v1?

Yes sir it is the version vsftpd_v1.
Do I need to make any changes to vsftpd.conf file?

No, changes to config file would not be needed for benchmarking.
You source ~/ftp_server/testfile is effectively /home/crio-user/ftp_server/testfile
which is the same as the destination, correct?

Yes sir, they are the same destination.