421 Service not available, remote server has closed connection

I am getting this error I also tried to solve this from forum but it did not work for me.
ftp_conn

You need to run the Qbox process as root.
And run ftp as normal user

when I get "root@~# " console it is not work vsftpd_v1… command

First, check the permission of file using ls -l
you need to change the owner of file to root using chown command
look for that command online.
And then run the Qbox as root

It did not work for me Please help me with this.
chown

So you dont need to change directory to run any file as root.
There is a command available.
Google it.

but it will show cannot read config file

ftp 0.0.0.0 8081 Connected to 0.0.0.0. 220 (vsFTPd 3.0.3) Name (0.0.0.0:crio-user): root 331 Please specify the password. Password: 421 Service not available, remote server has closed connection Login failed. No control connection for command: Success

Now I can able to run QBox as root but I am getting this error.

1 Like

qbox host is the one that is stated in your workspace. Your IP

Do I have to run ftp <my-ip> 8081 ??

Try it once. You got it

I tried it but it shows… connection timed out

ftp 3.6.151.215 8081
ftp: connect: Connection timed out
ftp> pwd
Not connected.
ftp> !pwd
/home/crio-user/workspace/ftp_server
ftp>

use the ftp from ftp_client directory

I tried it bu it showing same result

send a screenshot of error

ftpclienterro

go to QBox directory
and then try the same

again same thing happen with this

check if the qbox server is running

The FTP Server should run on localhost please try again.