421 Service not available, remote server has closed connection-module 3 : milestone 2

I Have tried all the solutions mentioned in the forum but still facing"421 Service not available, remote server has closed connection " issue…
my .conf file has all these options

run_as_launching_user=YES
anonymous_enable=NO
local_enable=YES
write_enable=YES
listen_port=8081
vsftpd_log_file=/home/crio-user/workspace/vsftpd.log
xferlog_std_format=NO
syslog_enable=NO
log_ftp_protocol=YES
ftp_username=nobody

yes i am also facing the same issue , have you solved it .

ya …i had solved it . set run_as_launching_user option=NO
doing this and further creating empty directory solved my issue. :slightly_smiling_face:

i tried that but after turning run_as_launching_user=NO , its now giving me 500 oops error .

hey i changed some things but now its giving me error message.
500 OOPS: vsftpd: not found: directory given in ‘secure_chroot_dir’

can you help me.

Ya so may be it is asking for creating some empty directory… do so …issue will be resolved most probably.

Is your issue resolved?

Yes… it is resolved now