421 error whene anonymous=NO and local _enable=yes

In module 3 I stuck on last MILESTONE, using crio-user and password for ftp LOGIN but it give 421 error. It is permission issue or vsftpd.config, where I have to do changes.

If it is a permission issue try to change file permissions with ‘chown’ command.

I don’t know what it is. Want suggestion

I’m in the same situtaion. I tried the chown command but im still getting that error

There are three possibilities for the root cause of this error.

  1. The IP address is not defined in /etc/hosts, so go into that file and add ‘127.0.0.1 workspace’ then save that file.
  2. The port 8081 is already being used. So in that case you have to see the processes and kill the vsftpd processes. Please gogle on how to kill processes in linux for more information regarding how to kill a process.
  3. Firewall is not letting you connect.
    https://bobcares.com/blog/ftp-error-421-service-not-available/
    Use this website as a reference.

there is already a "127.0.0.1 localhost " in that file, should it be replaced with “127.0.0.1 workspace” ?

Check vsftpd.config carefully.

using sudo with ftp command worked for me.

1 Like

thanks man, this works for me.

1 Like