200 PORT command successful. Consider using PASV. 550 Permission denied

what am i missing in my conf file in module 3 milestone 2

anonymous_enable=NO

ftp_username=crio-user

secure_chroot_dir=/home/crio-user/workspace/usr/share/empty
local_enable=YES

pasv_promiscuous=YES
dirmessage_enable=YES

xferlog_enable=YES

connect_from_port_20=YES
listen=YES

listen_port=8081

vsftpd_log_file=/home/crio-user/workspace/vsftpd.log

xferlog_enable=YES

xferlog_std_format=NO

syslog_enable=NO

log_ftp_protocol=YES

you need to enable passive, flag is pasv_enable.

now i m getting new error
Connected to 0.0.0.0.
421 Service not available, remote server has closed connection

when you are getting the error exactly. i mean in connecting the ftp or downloading or uploading

Connecting ftp , it shows this error

you are listening on port 8081, so disable the connect from port 20.
and make sure your host ip is right.

Hey you don’t have to add any extra options that are not mentioned in the taskboard.
Go through the config file and understand as to what has to be done.
Use the taskboard. :slight_smile:

after many ftp requests i m getting this error
Connected to 0.0.0.0.
421 Service not available, remote server has closed connection, intially it was fine

Check 2 paricular boolean options in your config file,
one of them is used to enable local ftp users,
and the other option gives write permission to system commands.

both are set to yes in config file , intially it was working fine

there’s another error in the config file as far as I can see, you are trying to access 2 ports at the same time.

it is still not working

did you remove the particular option that I said, it should work, go through the forum and understand as to what has caused your problem.

i have to disable connect_from_port_20=YES this ?

Yes, accessing 2 ports at the same time is probably causing this issue.

I have a question: when in put command, we didn’t specify the destination where the file will be transferred to, how does it know about it? Sorry if it sounds stupid.

It puts the file where you have started the ftp_server if you haven’t used the cd command after starting server.
Use pwd to know when in ftp to know where the files will be uploaded.

Thanks a lot. Really appreciate.

Does the same apply for get command as well?

yeah, same for the get.